В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
malinovaya14
malinovaya14
18.02.2021 05:58 •  Информатика

Написать программу, которая вводит массив и заменяет в нем все элементы, которые превышают 7, этим числом. вывести массив и кол-во замен.(в pascal)

Ответ:
tutuginovvan
tutuginovvan
25.05.2020 21:17

const  

n=10;

var  

a : array [1..n] of integer;

i,k,m : integer;

begin

randomize;

k:=0;

writeln('введите число, на которое заменять элементы: ');

read(m);

writeln('Массив:');

for i:=1 to n do  

 begin

   a[i]:=random(10)+1;

   write(a[i]:4);

 end;

writeln;

for i:=1 to n do  

 if (a[i]>7) then  

   a[i]:=m;

writeln('изменённый массив:');

for i:=1 to n do  

 write(a[i]:4);

end.  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?