В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Markizka22
Markizka22
22.06.2022 22:16 •  Информатика

Надо написать программу на паскале, без массивов. дано натуральное число. определить, сколько раз у этого числа встречается минимальная цифра. (например, при вводе числа 2618319, на экране должно быть "2").

Ответ:
7446457567
7446457567
02.10.2020 07:23
Var
  s:string;
  c:char;
  i,k:integer;
begin
  Write('Введите число: '); Readln(s);
  c:=s[1]; k:=1;
  for i:=2 to length(s) do
    if s[i]=c then Inc(k)
    else if s[i]<c then begin c:=s[i]; k:=1 end;
  Writeln('Наименьшая цифра ',c,' встретилась ',k,' раз(а)')
end.

Тестовое решение:
Введите число: 3141592653589793
Наименьшая цифра 1 встретилась 2 раз(а)
0,0(0 оценок)
Ответ:
nastyamagiao
nastyamagiao
02.10.2020 07:23
Var a, k, count: integer;
begin
readln(a);
k:=a mod 10;
a:=a div 10;
count:=1;
while(a<>0) do begin
  if(a mod 10 = k) then count+=1;
  if(a mod 10 < k) then begin
    k:=a mod 10;
    count:=1;
    end;
  a:=a div 10;
  end;
writeln(count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?