В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Alniri
Alniri
26.11.2020 14:29 •  Информатика

Нужно составить программу(ну как всегда varbegan ну и т.д.) дана дробь a/b. требуется ее сократить. то есть записать это же число в виде c/d, где c — целое число, d — натуральное число и d минимальное возможное.

Ответ:
polina150606
polina150606
25.05.2020 21:08

var i,a,b,a1:integer;
begin
readln(a,b);
a1:=a;
for i:=1 to a1 do begin
if (a mod i=0) and (b mod i=0) then begin
a:=a div i;
b:=b div i;
end;
end;
writeln('c=',a,' d=',b);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?