В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
мартина
мартина
20.09.2021 15:38 •  Информатика

Вычислить: номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.написать программу в

Ответ:
kakaxa2283
kakaxa2283
16.07.2020 20:53
const  n = 5;   var   a: array[1..n] of integer;   i, k: integer;   s: real;   begin   s := 0;   for i := 1 to n do   begin     readln(a[i]);     s := s + a[i];   end;   s := s / n;   writeln('Среднее значение = ', s:0:3);   k := 1;   for i := 2 to n do     if abs(a[k] - s) > abs(a[i] - s) then k := i;     writeln('Индекс элемента: ', k, ' Значение = ', a[k]); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?