В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lizapereverzeva1
lizapereverzeva1
03.05.2020 16:11 •  Информатика

Нужно написать программу, которая печатает true, если точка (x; y) принадлежит закрашенной области. pascale.

Ответ:
KseniaRogalina
KseniaRogalina
16.07.2020 01:15

var

 x, y: real;

begin

 read(x, y);

 if y <= -x + 4) and (y >= -x + 2) and (x >= 0) and (y >= 0))  

 or ((y <= x + 4) and (y >= x + 2) and (x <= 0) and (y >= 0))  

 or ((y >= -x - 4) and (y <= -x - 2)) and (x <= 0) and (y <= 0)))then

   write('true');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?