Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
LinaKosarchuk
05.07.2020 19:57 •
Информатика
Составить программу вычисления суммы квадратов первых n членов натурального ряда, каждое из которых при делении на m дает в остатке f. (паскаль)
Ответ:
sadnaadina00
15.07.2020 23:48
Var x, n, m, f, s: integer;
begin
write('Введите N: '); readln(n);
write('Введите M: '); readln(m);
write('Введите F: '); readln(f);
for x := 1 to n do
if(x mod m = f) then s := s + sqr(x);
writeln('Сумма: ', s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
sematom
22.01.2022 06:54
Program prim1; uses crt; var a,i: integer; begin read(a); i: =1; while i 10 do begin i: =i+1; write(a); end; end. это программа для того чтобы вывести 10 одинаковых...
Стас666228
22.04.2023 02:27
1. перевести три числа из десятичной системы счисления в двоичную. 2. перевести три числа из двоичной системы в десятичную....
anjela2288
14.11.2020 23:48
Клоун предложил каждому из публики задумать число. потом он сказал: «прибавьте к задуманному числу 5. теперь из результата вычтите 2. а теперь к результату прибавьте...
eviljew1
14.11.2020 23:48
Определите, что будет напечатано в результате работы следующей программы. var s, n: integer; begin s: = 1; for n: = 5 to 8 do s: = s * 3; write(s); end. ответ: введите...
Peregudovapolina
10.08.2021 21:06
Сколько битов состовляет смс содержащие 0.125 кбайтов...
Васютка3333
21.04.2021 12:24
Объясните написание букв о в слове молоко...
AngelinaMon1
21.04.2021 12:24
Решите 823 разделить на 7 в столбик с остатком...
ES2017
21.04.2021 12:24
Составить 5 предложений на каз тема мои игрушки...
markasolnce2103
21.04.2021 12:24
Упорядочите по возрастанию все натуральные числа вида: з) abcd,где a,b,c,d, -последовательные числа ж) , m≥7...
nelyagedo
21.04.2021 12:24
Востановите в таблице отсутствующие названия орфограмм 1 столбик...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('Введите N: '); readln(n);
write('Введите M: '); readln(m);
write('Введите F: '); readln(f);
for x := 1 to n do
if(x mod m = f) then s := s + sqr(x);
writeln('Сумма: ', s);
end.