Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
АлiнаКукушкiна
18.04.2023 02:48 •
Информатика
Язык си. написать программу заполнения односвязного списка значениями и вывода этих значений. , .
Ответ:
Fkbyfitdxtyrj
02.10.2020 05:40
выбирай
#include <stdio.h>
#include <stdlib.h>
struct LIST {
int number;
struct LIST *next; };
//
void Push(struct LIST** list, int number) {
struct LIST* node = malloc(sizeof(struct LIST));
node->number = number;
node->next = *list;
*list = node; }
//
void Print(const struct LIST* list) {
if (list) {
Print(list->next);
printf("%d ", list->number); } }
//
int main() {
int i = 10;
struct LIST* list = NULL;
while (i--) {
Push(&list, i + 1); }
//---(это разделение разных программ)
0,0
(0 оценок)
Популярные вопросы: Информатика
11Аслан11
25.02.2020 08:24
Сколько килобит содержит файл объемом 1024 бита...
mssvetochkaki
25.02.2020 08:24
Сколько ди скет объемом 360 кбайт необходимо для хранения учебника объемом 120 страниц, в каждой из которых 48 строк по 60 знаков...
instajohap091g2
25.02.2020 08:24
Скорость передачи данных по сети равна 1мбит /с .передас файла через данное соединение заняла 3 секунды .определите размер файла в килобайтах...
saha1710
25.02.2020 08:24
Для хранения области экрана монитора размером 128*64 точек выделено 16 кбайт оперативной памяти. какое максимальное число цветов допустимо использовать для раскраски...
milana368
25.02.2020 08:24
Сколько кб составит сообщение из 130 символов 29-символьного алфавита?...
lenokv
31.08.2022 18:23
Определить текущую аппаратную конфигурацию вашего персонального компьютера: - производитель материнской платы и основной чипсет; - используемый процессор (фирма производитель,...
женя1362
10.01.2021 19:37
Решить тест по информатике...
Nyoken
07.05.2022 21:01
Какие существуют угрозы безопасности в сети? Какие существуют риски при пользовании интернетом, и как их можно снизить? Какие виды мошенничества существуют в сети Интернет? Как...
Помагайтыыыы
08.05.2022 16:59
Назови первый предмет который отражает свет...
Dvorchnik8196
08.05.2022 16:59
Какие понятия появились в ходе проведения реформ 1860-1870 гг. в Российской империи? (3 варианта ответов) 1. хутор 2. фольварок 3. барщина 4. суд присяжных 5. оброк 6. выкупные...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <stdio.h>
#include <stdlib.h>
struct LIST {
int number;
struct LIST *next; };
//
void Push(struct LIST** list, int number) {
struct LIST* node = malloc(sizeof(struct LIST));
node->number = number;
node->next = *list;
*list = node; }
//
void Print(const struct LIST* list) {
if (list) {
Print(list->next);
printf("%d ", list->number); } }
//
int main() {
int i = 10;
struct LIST* list = NULL;
while (i--) {
Push(&list, i + 1); }
//---(это разделение разных программ)