Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Cronus1Oleg
26.08.2021 11:33 •
Информатика
Cи написать программу, считывающую с клавиатуры 32-битное беззнаковое число n, числа a и b и выводящую на экран число, равное исходному n, но с установленным битом номер a и снятым битом номер b
Ответ:
vovaaan1
02.10.2020 05:36
#include <iostream>
using namespace std;
int main() {
unsigned int n,a,b;
cin>>n>>a>>b;
n&=1<<a;
n&=(0x)-(1<<b);
cout<<n;
return 0;
}
Что-то в этом духе
0,0
(0 оценок)
Популярные вопросы: Информатика
zhenya28081999
17.08.2021 08:08
Задача №2 Роб хочет покормить котика. Но пока он несёт еду, котик может отойти от своей клетки на 1 клетку вправо, влево, вверх или вниз. По диагонали котик ходить не умеет...
ынпщщ357
20.11.2022 16:19
Что значит социальные сети высоких технологий?...
madinagiraevaM
26.06.2020 09:14
У героя «Майнкрафта» Алекса есть машина, которая выпускает по четыре минерала в минуту. На каждые 100 минералов можно построить новую машину, которая также выпускаем по четыре...
алина3687
23.03.2020 15:55
Найди правильный ответ. Даша работала с каталогом D:\Документы\Материалы\Заготовки. Сначала она поднялась на один уровень вверх, затем спустилась в каталог Изображения, после...
zol1981
06.03.2020 14:00
2. Определи информацию по видам восприятия D) Обонятельная E) Тактильная А) Слуховая C) Зрительная...
natochkaa333
02.01.2023 03:30
НАДО У исполнителя Вычеслитель 2 комманды котороым присвоены номера: 1. Умножь на 5. 2. Вычти b. (b - неизвестное натуральное число) Первая из них увеличивает число на экране...
stetcenko87
22.07.2020 05:16
Дано натуральное число N. Требуется получить и вывести на экран количество всех возможных различных представления этого числа в виде суммы натуральных чисел (то есть, 1 + 2...
razi2008900
28.05.2023 01:25
На одном физическом компьютере могут одновременно работать сколько виртуальных машин?...
Бика2525
21.12.2022 02:44
Написать функцию, проверяющую является ли десятичное число x палиндромом в пятеричной системе счисления. Функция должна возвращать True или False. При данной функции вывести...
ibraevaira
31.08.2020 04:13
Как определить количество определенных слов в c#...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main() {
unsigned int n,a,b;
cin>>n>>a>>b;
n&=1<<a;
n&=(0x)-(1<<b);
cout<<n;
return 0;
}
Что-то в этом духе