В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
katrinzeta18
katrinzeta18
29.12.2022 15:15 •  Информатика

Написать программу вычисления стоимости покупки с учетом скидки 3% сумма больше 200 рублей

Ответ:
Anton3228
Anton3228
02.10.2020 05:48
Для PascalABC:

program Project1;
var i:real;
begin
write('Введите стоимость товара ---> ');
readln(i);
writeln('С учётом скидки товар будет стоить ', i*0,03, ' рублей');
end.

Для Delphi:

var i:real;
begin
write('Vvedite stoimost tovara ---> ');
readln(i);
writeln('S ychetom skidki tovar bydet stoit ', i*0,03, ' ryblei');
readln;
end.

Написал два варианта, так как синтаксис и некоторые моменты немного отличаются с использованием Delphi и PascalABC.
0,0(0 оценок)
Ответ:
mariabilyk2005
mariabilyk2005
02.10.2020 05:48
Наверное, имелось ввиду, что скидка будет, если сумма более 200 рублей?

var x: integer;
begin
  write('Введите цену: '); read(x);
  if(x > 200) then writeln('Скидка 3%! Стоимость покупки:', (x * 0.97))
  else writeln('Скидки нет! Стоимость покупки: ', x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?