В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
SEITZHANOFF
SEITZHANOFF
08.12.2021 01:10 •  Информатика

Составить программу, решающую следующую : дано число а. не пользуясь никакими другими операциями, кроме умножения, получить: за 3 операции.

Ответ:
senyazer
senyazer
15.07.2020 21:52
\displaystyle x=a^8={((a^2)^2})^2={((a\times a)^2)}^2 \\ a_1:=(a\times a); \ a_2:=(a_1\times a_1); \ a_3:=(a_2\times a_2)


var
  x,a,b:longint;
 
begin
  a:=3;
  a:=a*a;
  a:=a*a;
  x:=a*a;
  Writeln('3 в степени 8 равно ',x)
end.

Тестовое решение:
3 в степени 8 равно 6561
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?