В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lizka119
lizka119
04.12.2022 19:52 •  Информатика

Составить программу,которая формирует одномерный массив и выводит на экран все элементы,кратные 7.

Ответ:
daurova2007
daurova2007
02.10.2020 05:31
Const
n=10;
var
a:array[1..n]of integer;
i,k:integer;
    begin
        for i:=1 to n do
               begin
                   a[i]:=random(100);
                    write(a[i]:4);
                end;
writeln; 
           for i:=1 to n do
                if a[i] mod 7=0 then
                 begin
                      write(a[i]:4);
                      k:=k+1;
                 end;
if k=0 then
    writeln('нет кратных 7')
end.

          
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?