В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1939345
1939345
27.02.2020 04:27 •  Информатика

Составить программу: сформировать в памяти массив из 15 целых чисел.изменить массив так,чтобы числа под чётными номерами были удвоены,а на нечётных-заменены нулями.

Ответ:
арвгшвш
арвгшвш
02.10.2020 05:31
var
  a: array [1..25] of integer;

begin
  for i: integer := 1 to 25 do
  begin
    a[i] := random(255);
    writeln(i, ' => ', a[i]);
  end;
  writeln('');
  for i: integer := 1 to 25 do
  begin
    if (i mod 2 = 0) then
      a[i] := a[i] * 2
    else
      a[i] := 0;
    writeln(i, ' => ', a[i]);
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?