В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nadir1234
nadir1234
26.09.2021 12:11 •  Информатика

Написать программу, которая вводит с клавиатуры последовательность из 10 вещественных чисел, считает сумму и среднее арифметическое этих чисел. нужно составить блок-схему для этой .

Ответ:
tomas787
tomas787
02.10.2020 05:10
Pascal

var
   a,s, r : real;
   i : integer;

begin
 for i := 1 to 10 do
 begin
 readln (a);
 s := s +a;
 end;
r := s/r;
writeln ('sr=',r:3:2);
writeln ('s=',s:3:2);

end.
0,0(0 оценок)
Ответ:
Viktoria2025
Viktoria2025
02.10.2020 05:10
Var
 i:integer;  
 a,sum,s:real; 
begin    
for i:=1 to 10 do     
   begin         
    read(a);
    sum:=sum+a;      
   end;    
 write('Сумма: ',sum);   
 s:=s/10;     
write('Cреднее арифметическое: ',s);
 end.
Написать программу, которая вводит с клавиатуры последовательность из 10 вещественных чисел, считает
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?