В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lavrinenkoll
lavrinenkoll
17.05.2023 22:31 •  Информатика

Паскаль составить программу для проверки, можно ли заданное натуральное число n представить в виде куба простого числа.

Ответ:
T1mon4ikRYTP
T1mon4ikRYTP
15.07.2020 17:28
Var n,k,m:integer;
begin
readln(n);
for k:=1 to n do
begin
m:=k*k*k;
if m=n  then 
begin
writeln(k,'*',k,'*',k,'=',n);
exit;
end;
end;
if (m<>n) then 
writeln('Het');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?