В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Julia8546
Julia8546
26.03.2023 15:12 •  Информатика

С. напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. если отрицательных элементов нет, то сообщить об этом) p.s. в паскале

Ответ:
Христина854
Христина854
15.07.2020 17:11
Var
  n, i, s, k:integer;
  a:array [1..30] of integer;
begin
  writeln('Vvedite massiv');
  for i:=1 to 30 do
  readln(a[i]);
  writeln('Massiv');
  for i:=1 to 30 do
  write(a[i],' ');
  writeln();
  k:=0; s:=0;
  for i:=1 to 30 do
  if a[i]<0 then
  begin
  s:=a[i]+s;
  k:=1;
  end;
  if k=1 then
  writeln('Summa otricatelnih elementov: ',s)
  else
  writeln('Otricatelnih elementov net');
  readln();   
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?