Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
2006197909876
14.08.2021 21:37 •
Информатика
Напишите программу, которая вычисляет нод двух чисел. используйте функцию. напишите программу, которая вычисляет нок двух чисел. используйте функцию.
Ответ:
dem0N1
15.07.2020 13:54
Программа с НОД
var t,t1,x,y,z:integer;
Function NOD(a, b: integer): integer;
Begin If a=b then NOD:=a
else if a>b then NOD:=NOD(a-b, b)
Else NOD:=NOD(a, b-a);
End;
begin
writeln('Введите 2 числа');
readln(x,y);
t:=NOD(X,Y);
writeln(t);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
radion2005
01.06.2020 19:43
Основные возможности электронных таблиц: 1построение диаграмм требуемого вида 2коллективное использование данных, хранящихся в таблицах, распространение и просмотр электронных таблиц...
sveta760
30.10.2021 07:12
, напишыте просто сколько шагов...
AlexeyB96
26.04.2021 07:24
Быстрее , 30 минут до конца урока...
VafaMurad
23.08.2022 16:11
Python 3.6 + Требуется найти n-ое число в последовательности простых чисел. Формат входных данных Вводится одно натуральное число n (1≤n≤15000). Формат выходных данных Требуется...
adadasda65p06utn
13.08.2020 17:40
Задача на С++ Треугольник Вам даны 4 отрезка. Выведите YES, если среди них найдутся 3, из которых можно составить треугольник, и NO в противном случае. Для решения напишите функцию...
marmishenka
11.10.2022 02:49
Оценить надёжность по модели Шумана (в приложенном файле):...
elenaklass1
02.11.2022 12:19
Вычисли значение математического выражения в MS Excel: (85+176)−2(75:(7+16)). (ответ округли до сотых)...
Danyaukos
05.09.2022 10:57
9. Как можно переместить курсор к обнаруженной ошибке? ...
лёдсовкусомпохмелья
12.12.2021 02:06
КТО РАЗБИРАЕТСЯ В PYTHON РЕШИТЕ PLEASE ЭТУ ЗАДАЧУ Электронный попугайБоба очень любит попугаев, но у него аллергия на птиц. Поэтому он захотел создать себе электронного попугая.Напишите...
NastushaJol
14.04.2023 04:24
Какое оборудование употребляется для разметки области рисования?Прокомментируйте действие клавиш CTRL+D.Объясните функцию волшебной палочки....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var t,t1,x,y,z:integer;
Function NOD(a, b: integer): integer;
Begin If a=b then NOD:=a
else if a>b then NOD:=NOD(a-b, b)
Else NOD:=NOD(a, b-a);
End;
begin
writeln('Введите 2 числа');
readln(x,y);
t:=NOD(X,Y);
writeln(t);
end.