В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Vladijad
Vladijad
28.02.2022 18:53 •  Информатика

Составить программу в паскале для определения является ли заданное слово палиндромом

Ответ:
KristaYu
KristaYu
15.07.2020 11:55
Var 
x:string;
i,w:integer;
begin
w:=0;
readln(x);
for i:=1 to length(x) div 2 do
if x[i]<>x[length(x)-i+1] then
w:=w+1;
if w=0 then writeln('Палиндром') else
writeln('Не палиндром');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?