В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vika2007
vika2007
13.03.2021 02:33 •  Информатика

Напишите программу в pascalabc которая на вход получает 3 вещественных числа и выводит на экран большее из них.

Ответ:
миёк2
миёк2
02.10.2020 05:02
Var 
x,y,z:real;
begin
writeln('Введите три числа');
read(x,y,z);
If (x>z) and (x>y) then
writeln('Наибольшее= ',x);
If (y>z) and (y>x) then
writeln('Наибольшее= ',y);
If (z>x) and (z>y) then
writeln('Наибольшее= ',z);
If (z=y) and (y=x) then writeln('Все числа одинаковые') else
begin
If (z=x)  then writeln('числа x и z равны');
If (y=x)  then writeln('числа x и y равны');
If (z=y)  then writeln('числа y и z равны');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?