В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
петя1023
петя1023
27.03.2022 17:58 •  Информатика

Составить программу, которая вычисляет произведение сомножителей: (1+1/1)(1+1/4)(1+1/9)(1+1/16)(1+1/25)(1+1/36)… вычисление происходит до тех пор, пока произведение сомножителей не станет больше, чем 3.6. в ответе написать количество сомножителей для данного вычисления. в ответе указать только число, например, 15

Ответ:
tapilina92
tapilina92
15.07.2020 08:34
Var i, ans : integer;
pr : real;
begin
    i := 1;
    pr := 1;
    ans := 0;
    while (pr <= 3.6) do begin
        pr *= (1 + 1 / (i * i));
        i := i + 1;
        ans := ans + 1;
    end;
    writeln(ans);
end.

48 сомножителей
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?