В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
moda712
moda712
30.01.2020 07:58 •  Информатика

Составить программу оценки на соревнованиях по фигурному катанию выставляются 9 судьями. потом одна самая высокая и самая низкие оценки отбрасываются и в зачет идет среднее арифметическое оставшихся оценок. составьте программу, которая определяет зачетную оценку спортсмена. оценки судей ввести в клавиатуры (целые числа от 1 до 6)

Ответ:
dimakrochak
dimakrochak
14.07.2020 13:27
Var
   max,min,i:integer;
   b:real;
   a:array[1..9]of integer;
begin
for i:=1 to 9 do
  begin
  while (a[i]<1) or (a[i]>6) do
    begin
    write(i,' оценка: ');
    readln(a[i]);
    end;
  if i=1 then
    begin
    max:=a[1];
    min:=a[1];
    end;
  if a[i]>max then max:=a[i];
  if a[i]<min then min:=a[i];
  b:=b+a[i];
  end;
b:=(b-min-max)/7;
writeln('Зачетная оценка: ',b);
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?