Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
iweriooo
30.06.2021 05:50 •
Информатика
Паскаль! вычислить квадрат суммы цифр заданного четырёхзначного числа
Ответ:
Владислава3000
13.07.2020 23:24
Program x;
var a,b,c,d,n:integer;
begin
writeln("введите четырехзначное число");
readln(n);
a=n div 10;
b=(n div 100) mod 10;
c=(n mod 100) div 10;
d=n mod 10;
writeln("ответ: ", Sqr(a+b+c+d));
0,0
(0 оценок)
Популярные вопросы: Информатика
Lilit66696
18.10.2022 21:35
Написать программу на языке Рascal для решения задачи: Ввести с клавиатуры значения 15 элементов массива, содержащего вещественные числа. Значение каждого элемента массива увеличить...
ЭммаУаилд
30.03.2021 19:29
Напишите программу на паскале (8 класс)...
vadik46
09.12.2021 10:00
Определи, из каких элементовсостоит диограмма Верных ответов:3 настройка линии значения ячейки линия тренда название осей легенда...
makeevaed
11.11.2022 14:22
а)0,1101б)6037в)378,921)113 в 8 и 16 бит2)из б в 32...
Dan1L1an
13.01.2021 04:20
Який результат ми отримаємо в середовищі табличного процесора Microsoft Office Excel, якщо вкажемо продемонстровану формулу? =2+3*7 Виберіть одну відповідь: 35 42 помилка 23...
msimaratp08h7f
06.05.2023 19:16
, сделать в виде таблицы истинности F = X И НЕ (Y или Z) F = X И (Y или Z)...
зузу12
04.05.2021 22:16
Решите задачу с таблицы, Покажите полное решение. Друзья Даниил, Артём и Анатолий участвовали в спортивнон турнире. На них были спортивные костомы красного, синего и зелёного цветов....
зяйка75542
16.10.2020 18:44
С какими видами информации работает каждое поколение ЭВМ(расписать первое, второе, третье и четвёртое)...
FlowerBlue17
19.07.2020 00:09
Перемещая элементы снизу, восстановите пропущенные обозначения в структурной схеме компьютера....
kolikova05
15.12.2021 12:37
.Выберите возможности электронного процессора Верных ответов: 2 создание текстов Выполнение расчетов создание изображений построение графика...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,b,c,d,n:integer;
begin
writeln("введите четырехзначное число");
readln(n);
a=n div 10;
b=(n div 100) mod 10;
c=(n mod 100) div 10;
d=n mod 10;
writeln("ответ: ", Sqr(a+b+c+d));