В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lolipop891
lolipop891
20.08.2020 02:22 •  Информатика

Синформатикой. нужно составить программу которая удалит из текста все цифры( использование pos,copy,delete,insert)

Ответ:
petrovaanastasia26
petrovaanastasia26
02.10.2020 03:21
for i:=1 to length(s) do if s[i] in ['1'..'9'] then sum:=sum+ord(s[i])-48;//здесь ноли не считаем, от них сумма не меняется writeln('Сумма цифр в тексте='sum); if sum>5 then  begin   for i:=lengrh(s) downto 1 do   if s[i] in ['0'..'9'] then delete(s,i,1);   write(s);  end else write('Цифры не удаляются!');
0,0(0 оценок)
Ответ:
SeverinaWinter
SeverinaWinter
02.10.2020 03:21
ВОТ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?