В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
fagev
fagev
26.06.2021 21:34 •  Информатика

1. написать программу, решающую уравнение ax=b. предусмотреть все варианты для значений a и b. 2. идет к-ая секунда суток. определить, сколько целых часов и целых минут с начала суток. на экран вывести фразу: «it is … hours … minutes». 3. вводится пятизначное число. найти сумму цифр этого числа. написать программы в паскале.

Ответ:
Liza16052006
Liza16052006
25.05.2020 16:53

1.

 

program simple;

var a,b:integer;

begin

 writeln('daite a, b); readln(a,b);

 writeln('x = ', b/a); readln;

end;

 

2.

 

program day;

var h,hours,minutes:longint;

begin

  writeln('daite secundi'); readln(h);

  hour:= h div 3600; minutes:=h mod 36000;

  if (minutes > 60) or (minutes=60) then 

   begin

     hour:=hour+1;

     minutes:=minutes-60;

  end;

  writeln('It is 'hours' hours 'minutes' minutes');

readln;

end;

 

3.

 

program summaChisla;

var s:string; i,sum: longint; c,cod:integer;

begin

  writeln('daite nomer); readln(s);

  for i:=1 to length(s) do

   begin

      val(s[i],c,cod); sum:=sum+c;

   end;

writeln('summa :',sum); readln;

end;

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?