В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
evaklchn
evaklchn
01.02.2021 12:37 •  Информатика

Дано натуральное число. написать программу, которая определит является ли число двузначным. ответ: true или false и является ли четной сумма его цифр. 50 .​

Ответ:
Пеннивайз2000
Пеннивайз2000
25.05.2020 16:45

Python:

a = int(input())

s = 0

print("True") if len(str(a)) == 2 else print("False")

for i in str(a):

  s+=int(i)

print("сумма цифр чётная") if s % 2 == 0 else print("сумма цифр не чётная")

0,0(0 оценок)
Ответ:
lckzgizigzly
lckzgizigzly
25.05.2020 16:45
var  number: integer;begin  Readln(number);  if (number >= 10) and (number <= 99) then    begin      Writeln('True');      if (number div 10 + number mod 10) mod 2 = 0 then        Writeln('Сумма цифр чётна.')      else        Writeln('Сумма цифр нечётна.');    end  else    Writeln('False');end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?