В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AkimMen
AkimMen
30.01.2020 10:27 •  Информатика

Напишите программу с паскаля: дана последовательность 5 9 13 17 21 25 29 33 37 41 45 49. составьте программу для подсчета числа слагаемых сумма которых равна 324

Ответ:
serovv751
serovv751
25.05.2020 16:29

var sum, i, s: integer;  //обыявляем необходимые переменные

//sum - сумма, i - кол-во слогаемых, s - само слогаемое

begin  //начало
  sum := 0; i := 1; s := 5;  //первое слогаемое = 5
  while (sum < 324) do  //пока сумма меньше 324
  begin
    sum := sum + s;  //к сумме прибавляем слагаемое
    s := s + 4;  //увеличиваем слогаемое
    i := i + 1;   //увеличиваем кол-во слогаемых
  end;
  writeln ('Слогаемых: ');  // выводим кол-во слогаемых
  write (i);
end.  //конец

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?