В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yanaprosandeeva
yanaprosandeeva
11.01.2022 09:14 •  Информатика

Решить в паскале. с клавиатуры вводится время суток в часах (от 1 до 24). необходимо составить программу, которая будет выводить на экран согласно введенному времени. ввод: 1 вывод: доброй ночи

Ответ:
sumat2
sumat2
13.07.2020 10:31
Program myp;
var a:integer;
begin
readln(a);
if a = 1 then writeln('Доброй ночи');
end.
0,0(0 оценок)
Ответ:
NoraDun
NoraDun
13.07.2020 10:31
Var
  time : Integer;  begin
  writeln('Введите, который час: ');
    readln(time);
    if (time > 23) or (time < 0) then
   writeln('Так не бывает!')  else
    begin
      if ( time >= 0 ) and ( time < 6 ) then writeln('Доброй ночи!');
    if ( time >= 6 ) and ( time < 12 ) then writeln('Доброе утро!');
    if ( time >= 12 ) and ( time < 18 ) then writeln('Добрый день!');
    if ( time >= 18 ) and ( time < 24 ) then writeln('Добрый вечер!');
  end;  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?