В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
RoseSmit
RoseSmit
14.08.2022 03:27 •  Информатика

1. с клавиатуры последовательно вводятся десять чисел. написать программу на паскале,которая вычислит и выведет на экран сумму чисел,кратных 3. 2. с клавиатуры вводится число n. написать программу, которая вычислит и выведет на экран все его делители

Ответ:
shahmir2406
shahmir2406
13.07.2020 08:27
Ввод с клавиатуры одномерного массива целых чисел и вывод его элементов на экран с противоположным знакомProgram Massiv2; 
  const N=10;
  type { Раздел описания типов переменных. Эти типы определяет сам пользователь, то есть мы определяем тип одномерного массива из n целых чисел }
    Mas=array [1..N] of integer; { 1..N - тип индекса; для индекса выбран интервальный тип. то есть интервал целых чисел от 1 до N. где N определено в разделе const }
  var
      Line:Mas; { Line - одномерный массив, его тип определен нами как Mas }
      i:integer; {Переменная, хранящая индекс элемента массива, к которому идет обращение }
begin
{ Ввод массива с клавиатуры }
  for i:=l to N do { Обращение к элементам массива происходит в цикле, по очереди }
    begin { Начало цикла ввода элементов массива }
      write('Введите элемент с индексом ' ,i,' :');
      readln(Line[i]) { Обращаемся к i-му элементу массива (Line[l],Line[2] и т. д.)}
    end; { Конец цикла ввода элементов массива }
{ Вывод элементов происходит также в цикле:}
  for i:=l to N do { Перебираем все N элементов массива }
    write(-Line[i]:5); { 10 элементов выводятся в строку. Выводим все элементы массива с противоположным знаком }
  writeln; { После вывода массива элементов - переход на новую строку } 
  readln 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?