Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Alexandr2K17
08.08.2021 15:19 •
Информатика
1. составьте программу, выясняющую, есть ли в словах х и у одинаковые символы. 2. составьте программу, удваивающую в слове х буквы "б" и "а".
Ответ:
1505Анютка1505
13.07.2020 07:04
#include <iostream>
#include <string>
#include <Windows.h>
int main()
{
SetConsoleCP(1251);
SetConsoleOutputCP(1251);
std::string x, y;
std::cin >> x >> y;
//1
bool same= false;
for (auto i : x){
for (auto j : y){
if (i == j) {same = true; break;}
}
if (same) break;
}
std::cout << std::boolalpha << same;
//2
for (unsigned int i = 0; i < x.size(); ++i)
if (x[i] == 'а' || x[i] == 'б') x.insert(x.begin() + i, x[i]);
std::cout << x;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
axeltrofimsky
04.04.2022 23:59
C) abs(a)*b; D) a/b.8. Ввод данных с клавиатуры осуществляется с оператора:А) write, writelnB) printC) inputD) math9. Выберите правильный вариант вывода на экран значения пере-менной...
MITSUHA
05.03.2020 16:13
Что делает в программе следующая строка? for i: =1 to 10 do read(m[i]); а) пересчет массива от 1 до 10; b) заполнение массива; c) ввод в массив десяти имен переменных; d) сортировка...
alapova1
05.03.2020 16:13
Удвоить трехзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае. если введенное число не трехзначное,...
Polina212
25.05.2023 20:57
Scoolnet.kz информатика 8 классс информатикаЗадача 1. Информационное сообщение объемом Y=375 байтов содержит K=500 символов. Какова мощность алфавита N? Для решения задачи впиши пропущенные...
tyanhinata
21.03.2021 13:22
Даны два целых числа. Определить, равны ли они. Вывести Yes , если эти числа равны и No в противном случае....
vikaviktoriyk1
29.12.2021 15:26
Не ((x 50) или не (x четное) найти наибольшее число x,для которого ложно высказывание...
acononencko201
14.02.2020 05:32
Гамма си бемоль мажор,от звука до-б3 и б53...
kombat1488
14.02.2020 05:32
Каково участие России в международном разделении труда и международной торговле?...
dinaras44
14.02.2020 05:32
Составить один изомер и один гомолог для 2-бром-3-метилбутан...
Glebbb15
14.02.2020 05:32
2.Магнітний потік, що пронизує контур провідника, рівномірно змінивсяна 0,6 Bб так, що EPC індукції стала дорівнювати 1,2 В. Визначити часзміни магнітного потоку. Обчислити силу індукційного...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <string>
#include <Windows.h>
int main()
{
SetConsoleCP(1251);
SetConsoleOutputCP(1251);
std::string x, y;
std::cin >> x >> y;
//1
bool same= false;
for (auto i : x){
for (auto j : y){
if (i == j) {same = true; break;}
}
if (same) break;
}
std::cout << std::boolalpha << same;
//2
for (unsigned int i = 0; i < x.size(); ++i)
if (x[i] == 'а' || x[i] == 'б') x.insert(x.begin() + i, x[i]);
std::cout << x;
return 0;
}