В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
thankay
thankay
06.01.2022 21:31 •  Информатика

Составьте программу, которая заполняет массив a [1..10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. выведите на экран исходный и полученный массивы

Ответ:
GGG123366699
GGG123366699
13.07.2020 07:04
Program dfg;
var
b,x,y:integer;
a:array [1..10] of integer;
d:real;
begin
randomize;
for x:=1 to 10 do
begin
y:=random(10);
a[x]:=y;
writeln ('числа случайные = ',y);
end;
a[1]:=a[1] xor a[10];
a[10]:=a[1] xor a[10];
a[1]:=a[1] xor a[10];
for x:=1 to 10 do
begin
writeln ('числа случайные после смены = ',a[x]);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?