В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Зимаа1
Зимаа1
12.02.2021 05:59 •  Информатика

Написать программу ,которая на вход получает число p.на входе определяет колличество его четных и нечетных делителей c++

Ответ:
lizamalaya2012
lizamalaya2012
13.07.2020 06:11
#include <iostream> 
int main() {
  int x, c=0, odd=0;
  std::cin >> x;

  for (int i = 1; i<=x; i++) 
    if (!(x%i)) {
      c++;
      if(i%2)
        odd++; 
    }
  std::cout << c - odd << " HE: " << odd << std::endl;
    
  return 0; 
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?