Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
vladvladc
09.11.2020 03:11 •
Информатика
Составить программу вычисления суммы цифр введенного с клавиатуры 3- х значного натурального числа . например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.
Ответ:
кукарека666555
02.10.2020 02:37
Program gt;
var n,s:integer;
begin
readln(n);
s:=(n div 100)+(n div 10)mod 10+(n mod 10);
writeln(s);
end.
каждая скобка это 1 2 3 цифра соответсвенно
0,0
(0 оценок)
Ответ:
1234567891248
02.10.2020 02:37
Var a,N,sum:word;
begin
Read (N);
Sum:=0;
While N<>0 do
begin
a:=N mod 10;
N:=N div 10;
Sum:=sum+a;
end;
Write (sum);
end.
Или по-простому еще так:
Var a,b,c,N:word;
begin
Read (N);
a:=N mod 10;
b:=(N mod 100) div 10;
c:=N div 100;
Write (a+b+c);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
dontgiveupDGU
10.01.2021 15:16
Задание 2 Для какого из приведённых имён ложно высказывание: НЕ (Первая буква согласная) ИЛИ НЕ (Последняя буква гласная)? 1. Иван 2. Михаил 3. Вера 4. Любовь...
firuzakushmano
21.01.2023 04:41
Придумать имя файла, в котором будет храниться изображение твоего любимого героя. выделить собственное имя и расширение...
gamezarif
21.01.2023 04:41
Петя зашифровал свой буквенный пароль, чтобы никто другой не смог его прочитать, но потом понял, что даже сам не может этого сделать. закодированный пароль представляет...
Плювиофил
21.01.2023 04:41
Объясните ошибки в следующих записях на языке паскаль. 1) sin(x 10). 2) false*not(true)-2. 3) x = 0 and round(sqrt(x)) mod 2 =0. 4) not not b or or d (переменные b и d...
Education26
16.12.2020 08:16
До ть будь ласка з відповіддю....
8479
22.05.2023 15:32
Составить программу для нахождения суммы чисел, кратных 7, в диапазоне от 0 до 100. Вывести на экран сумму чисел. Применить цикл с условием продолжения работы...
slisar4ukbogda
19.03.2022 03:12
Якими бувать помилки в проекті...
anastasiyalaza
20.12.2022 15:37
Как будет город сретенск на языке програмирования...
НеизвестныйНикнейм
04.09.2022 19:37
больше нет, чтобы задавать во Необходимо нарисовать 28 одинаковых вертикальных палочек. Дан алгоритм. Выбери верный ответ. использовать Чертежник алг черточки11 нач сместиться...
kmodeste
28.06.2021 19:23
Если слово арка закодировано числовой последовательностью 0100100010, (причем код согласных и гласных букв имеет различную длину) то какое слово по этому коду соответствует...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var n,s:integer;
begin
readln(n);
s:=(n div 100)+(n div 10)mod 10+(n mod 10);
writeln(s);
end.
каждая скобка это 1 2 3 цифра соответсвенно
begin
Read (N);
Sum:=0;
While N<>0 do
begin
a:=N mod 10;
N:=N div 10;
Sum:=sum+a;
end;
Write (sum);
end.
Или по-простому еще так:
Var a,b,c,N:word;
begin
Read (N);
a:=N mod 10;
b:=(N mod 100) div 10;
c:=N div 100;
Write (a+b+c);
end.