В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
FlowerBlue17
FlowerBlue17
20.06.2021 18:02 •  Информатика

Составьте программу заполнения массива а числами фибоначчи. в последовательности фибоначчи значения первых двух элементов равны 1, а значение каждого последующего элемента, начиная с третьего, равно сумме двух предыдущих. индексы элементов 1 2 3 4 5 6 7 8 9 10 значение элемента 1 1 2 3 5 8 13 21 34 55

Ответ:
merkurevamilena1
merkurevamilena1
02.10.2020 02:30
Program gt;
var a:array[1..10]of integer;
i:integer;
begin
a[1]:=1;a[2]:=1;
write(a[1],' ',a[2],' ');
for i:=3 to 10 do
begin
a[i]:=a[i-2]+a[i-1];
write(a[i],' ');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?