В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lord222435
Lord222435
22.05.2022 18:25 •  Информатика

Pascal. написать программу: нахождения цифры в числе с максимальным значением. 9й класс.

Ответ:
misheln
misheln
12.07.2020 23:57
uses crt;  
var a,Max,x:integer;  
begin      
  clrscr;      
  Write('Введите число: ');
  readln(a);      
  Max:=a mod 10;    
  while a>0 do          
   begin
          x:=a mod 10;
          a:=a div 10;
          if x>Max then Max:=x;
   end;
  Writeln('Максимальная цифра: ',Max);
  readln;  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?