Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
colaboyy7704ox6ktx
29.08.2021 07:23 •
Информатика
Разработать программу для перевода целых чисел из десятичной системы счисления в троичную и пятеричную. перевод оформить в виде подпрограмм.
Ответ:
hazina2
02.10.2020 02:27
Function to_base(n: integer; base: integer): integer;
begin
if n = 0 then
to_base := 0
else
to_base := (n mod base) + 10 * to_base(n div base, base);
end;
var
n: integer;
begin
readln(n);
writeln(to_base(n, 3));
writeln(to_base(n, 5));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
еджика
18.07.2022 17:36
только те элементы, значения которых кратно № вашего компьютера. (мой номер компьютера 12865241) Алгоритм: - заполнить массив элементами; - организовать цикл по суммированию элементов...
xotmirov1
24.06.2020 16:32
В компании трудятся специалисты (С), тренеры (Т) и финансисты (Ф). Каждый сотрудник имеет определенный уровень достижений – не меньше второго и не больше пятого; На диаграме отражено...
aaaaaa251
04.03.2022 01:18
Собственная внутренняя память человека внешняя память записные книжки, справочники, энциклопедии и т.д. любой материальный объект, используемый для фиксации и хранения на нём информации...
МегамозгМозг
15.01.2021 12:20
U=min(max(a,b)c) написать программу...
TUBERSUSLIK
15.01.2021 12:20
На флоте используется 5 разных флажков. для кодирования одного символа требуется 4 флага. сколько символов можно закодировать? ?...
Tanjusha576
11.08.2021 06:38
Площадь прямоугольного треугольника с катетами a и s равна 12(a+s). истинноеложноенельзя однозначно определить прям очень...
FinPinKin
07.09.2022 09:58
3,8m-(2,8m+0,7) если m=2,4: если m=8,57 найдите значение выражения...
sabinab13
07.09.2022 09:58
Решить уравнение. заранее ! -3x=-5...
youngest1111
07.09.2022 09:58
Покажи что стало символами власти царя ивана грозного? а)скипетр в) шапка монаха б) государство г) держава...
diksimail
07.09.2022 09:58
В1-м тысячелетии до нашей эры италию населяло много народностей, например латины (кто ещё? )...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
if n = 0 then
to_base := 0
else
to_base := (n mod base) + 10 * to_base(n div base, base);
end;
var
n: integer;
begin
readln(n);
writeln(to_base(n, 3));
writeln(to_base(n, 5));
end.