В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
7gklass2017
7gklass2017
14.06.2021 08:41 •  Информатика

Составьте программу, выводящую на экран числа от 1 до 10, а также их квадраты и кубы следующим образом: 1 1 1 2 4 8 3 9 27 10 100 1000

Ответ:
50АлисА05
50АлисА05
12.07.2020 21:30
Зависит от того, в чем работаете(Паскаль, С). Как самый просто вариант в паскале("в лоб"):
uses crt
var i:integer; 
begin
i:=1; {присваиваем 1}
repeat
 writeln(); {пустая строка}
 write(i); {пишем само число i}
 write(' '); {ставим пробел}
 write(exp(2*ln(i)):2:0);   {считаем квадрат числа i}
 write(' '); {пробел}
 write(exp(3*ln(i)):2:0); {считаем куб числа i}
 i:=i+1; {новое значение i}
until i>10; {условие окончания i>10}
readkey; {закрытие по нажатию программы}
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?