Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
vika1722
20.05.2021 09:08 •
Информатика
А. составьте подпрограмму-функцию, которая по заданному натуральному числу n вычислит сумму его цифр. б. составьте алгоритм, подсчитывающий количество n-значных натуральных чисел, у каждого из которых сумма цифр равна заданному натуральному числу k.
Ответ:
svetlana196420
12.07.2020 18:54
A.
Program enot;
Var a,c,sum: integer;
begin
read(a);
while a>0 do
begin
c:= a mod 10;
sum:=sum+c;
a:=a div 10;
end;
writeln(sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
UlyanaAleks
16.11.2020 14:46
Как называется преобразование из аналоговой формы в дискретную? АПЦ ПАЦ ЦАП АЦА...
ДжудиХопс12345
18.03.2023 13:55
напишіть програму введення двох чисел і знаходження їх суми. Якщо сума більша 20,то вивести її,в іншому випадку збільшити її на 5....
AngelChan2004
22.08.2022 04:54
Основні причини які спонукають людей створювати сайти...
akhtyamovedgar
10.08.2021 14:29
Сколько мегабайтов информации может поместиться на 17 CD дисках объёмом 720 МБ каждый...
маша3053
25.11.2021 03:13
Алг нач цел s,k ввод s ввод k если mod (s,k) =0 то вывод «ДА» иначе вывод «НЕТ» все кон было проведено 9 запусков программы, при которых в качестве значений переменных...
pelmenev777
24.11.2021 19:59
Выразите в байтах: 56 бит 1024 кб 1 мб...
Vlada722
24.11.2021 19:59
Вопрос: информация, хранимая в книгах, на магнитных носителях, грампластинках называется выберите один из 5 вариантов ответа: 1) архивной 2) внутренней 3) полезной...
Nika1337228
05.02.2021 17:24
Укажите режим, который соответствует стандартному дисплею в текстовом режиме. a. 80 x 25 color. b. 80 x 80 color. c. 256 x 80 color. d. 800 x 600 color....
baba22
05.02.2021 17:24
Двоичная запись которого содержит ровно три значащих нуля и две единицы. ответ запишите в десятичной системе счисления...
Ринацой
26.07.2021 10:47
Укажите наибольшее число , двоичная запись которого содержит ровно три значащих нуля и две единицы. ответ запишите в десятичной системе счисления...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Program enot;
Var a,c,sum: integer;
begin
read(a);
while a>0 do
begin
c:= a mod 10;
sum:=sum+c;
a:=a div 10;
end;
writeln(sum);
end.