В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
FrutikFresh
FrutikFresh
14.06.2021 19:32 •  Информатика

Составить программу: дано двухзначное число, определить входит ли число 4 и 7.

Ответ:
Q778
Q778
25.05.2020 15:16

То есть вопрос звучит так: состоит ли данное двузначное число из цифр 4 и 7?

Если так, то нужно всего лишь проверить, равно ли введённое число 47 или 74.

 

program test;
var n:integer;
begin
  write('Enter the number: ');
  readln(n);
  if (n = 74) or (n = 47) then
    writeln('numbers 4 and 7 included')
  else
    writeln('numbers 4 and 7 are not included');
readln();
end.

 

Хотя я подозреваю, что вместо и должно быть или.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?