В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
bosyakostya
bosyakostya
10.10.2021 22:59 •  Информатика

Составьте программу, заменяющую меньшее из двух данных чисел суммой, а большее – произведением этих чисел. с оператора выбора- case

Ответ:
1234567890821
1234567890821
12.07.2020 18:28
Var a,b,min,max,f:integer;
begin
readln(a,b);
min:=a+b;
max:=a*b;
if a>b then f:=1 else f:=2;
case f of
1: begin  a:=max; b:=min end; 
2: begin a:=min; b:=max end;
end;
writeln(a,b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?