В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DarPlay70
DarPlay70
27.06.2021 04:15 •  Информатика

Задан одномерный массив размером 40. определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10. вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

Ответ:
ruskei
ruskei
12.07.2020 15:49
Const
  n = 40;

var
  x: array[1..n] of integer;
  i, k, s: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  k := 0; s := 0;
  for i := 1 to n do
  begin
    x[i] := Random(50);
    Write(x[i]:3);
  end;
  Writeln;
  Writeln('Элементы со значением в интервале [7;10]');
  for i := 1 to n do
    if (x[i] >= 7) and (x[i] <= 10) then
    begin
      k := k + 1; s := s + x[i];
      Write(x[i]:3)
    end;
  if k = 0 then Writeln('не найдены')
  else Writeln(#13#10, ' Элементов:', k, ', среднее арифметическое=', s / k:5:3)
end.

Тестовое решение:

Элементы массива
 24 33 36 29 12  7  5 36  3 48 40 40 46  6 10 23 33  3 38 48 29 37 11 40 44 16 17 18 34 38 33 39  9  0 41 37 42  2 40 31
Элементы со значением в интервале [7;10]
  7 10  9
 Элементов:3, среднее арифметическое=8.667
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?