В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу 4. компьютер перебирает четные числа до тех пор, пока сума их квадратов не превысит s. чему равна сумма квадратов? подсказка: начальное значение переменной цикла – 2. шаг изменения – 2 (перебираем четные числа). считаем сумму квадратов до тех пор пока она меньше или равна s. вывод на экран : результат: s = тест 1: исходные данные: s = 24 результат: s =56 тест 2: исходные данные: s = 85 результат: s =120

Ответ:
krubtsova79
krubtsova79
12.07.2020 14:42
Program pr_1; 
var i,s,sq:integer; 
begin 
readln(s); 
i:=2; 
while sq<=s do 
begin 
sq:=sq+sqr(i); 
i:=i+2; 
end; 
writeln('sq=',sq); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?