В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
gvg1971
gvg1971
08.07.2020 08:06 •  Информатика

Нужно написать программу в паскале найти наименьшее общее кратное n натуральных чисел, используя алгоритм евклида.

Ответ:
карольчик1
карольчик1
12.07.2020 13:53
Var i, a, b, t, d, n : integer;
x : array of integer;
begin
    read(n);
    SetLength(x, n + 1);
    for i := 1 to n do
        read(x[i]);
    a := x[1];
    for i := 2 to n do begin
        b := x[i];
        d := a * b;
        while (b > 0) do begin
            t := a;
            a := b;
            b := t mod b;
        end;
        a := d div a;
    end;
    writeln(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?