В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Nezox1123
Nezox1123
08.07.2020 08:06 •  Информатика

Написать программу на паскаль дано натуральное число. вычислить количество цифр, являющихся степенями тройки (1,3,9).

Ответ:
dabby25
dabby25
12.07.2020 13:52
Var n, digit, ans : integer;
begin
    read(n);
    ans := 0;
    while (n > 0) do begin
        digit := n mod 10;
        if ((digit = 1) or (digit = 3) or (digit = 9)) then
            ans := ans + 1;
        n := n div 10;
    end;
    writeln(ans);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?