В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ВвОзДуХе
ВвОзДуХе
04.05.2020 01:44 •  Информатика

Требуется найти сумму цифр числа( )²,где 0< n< 19000. составьте программу.

Ответ:
Frank9110
Frank9110
12.07.2020 10:53
Стал ещё сильнее уважать свой ноут:)

uses
  System.Numerics;

var
  k, m: BigInteger;
  n, j: word;

begin
  readln(n);
  for j := 1 to n do
    k := k * 10 + 5;
  k := k * k;
  writeln(n, ' ', k);

  repeat
    m := m + (k mod 10);
    k := k div 10;
  until (BigInteger.Parse(k.toString()).isZero); //нет, isZero просто так не принимает IDE

  k := 0;
  writeln('Sum: ', m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?