В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составьте программу разложения данного натурального числа на простые множители. например, 200 = 2^3 × 5^2 × это умножить

Ответ:
muslima2003
muslima2003
02.10.2020 01:59

var

 n, i, k: integer;

begin

 repeat

   write('Введите натуральное число n= ');

   read(n);

 until n > 0;

 if n = 1 then writeln('Невозможно разложить на произведение простых множителей.')

 else

 begin

   write(n, '=');

   i := 2;

   while i <= n do

   begin

     k := 0;

     while n mod i = 0 do

     begin

       k := k + 1;

       n := n div i;

     end;

     if i < n then

     begin

       if k = 1 then write(i, '*')

       else if k > 1 then write(i, '^', k, '*');

     end

     else

     begin

       if k = 1 then write(i)

       else if k > 1 then write(i, '^', k);

     end;

     i := i + 1;

   end;

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?