Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Сирунс
02.11.2021 06:59 •
Информатика
Дан массив вещественных чисел x(x1? ).найти произведение положительных элементов массива и подсчитать их число.
Ответ:
RushShru
12.07.2020 08:54
Const n=5;
var
x:array[1..n]of real;
i,k:integer;
p:real;
begin
p:=1;
for i:=1 to n do
begin
readln(x[i]);
if x[i]>0 then
begin
p:=p*x[i];
k:=k+1;
end;
end;
writeln('p=',p);
writeln('k=',k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
аян45
23.12.2021 19:12
Вкакой системе счисления справедливо заданное равенство 88+44=110...
Даниссиммо1
23.12.2021 19:12
Составьте программу которая выводит на экран значения выражения 5n...
xasiyeva82p0c95p
23.12.2021 19:12
1. с кода unicode можно закодировать 65536 символов. каков информационный объем сообщения, набранного в этом коде: истинно велик тот человек, который сумел овладеть своим временем!...
reshetnicova74
15.07.2022 09:00
Что означает следующая запись 840х680?...
sladkaiakailinn
11.07.2020 10:09
Решить . дан массив в, состоящий из n элементов. элементы массива ввести с клавиатуры. найти сумму положительных и отрицательных элементов....
foben1
11.07.2020 10:09
Вкаком году была создана первая радиостанция?...
myrzik5293p081ps
11.07.2020 10:09
Пример разветвляющегося алгоритма.а)из повседневной жизни.б)из произведения.в)из любой предметной области,изучаемой в школе...
Ender222
04.06.2020 16:42
1. когда используются таблицы? 1) при создании текстовых документов, содержащих не большое количество однотипных данных. 2) при создании текстовых документов, содержащих большое...
valeraKRUT05
06.01.2020 12:59
Назовите приборы, автоматически представляющие человеку информацию о состоянии окружающей среды. 20 ....
В1и2к3т4о5р6и7я11
12.05.2020 11:25
Сторона правильного трикутника 8см. Знайдіть радіус вписаного та описаного кіл.....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
x:array[1..n]of real;
i,k:integer;
p:real;
begin
p:=1;
for i:=1 to n do
begin
readln(x[i]);
if x[i]>0 then
begin
p:=p*x[i];
k:=k+1;
end;
end;
writeln('p=',p);
writeln('k=',k);
end.