В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dali666
dali666
03.03.2023 20:39 •  Информатика

Составить алгоритм решения согласно своему варианту и написать программу на языке с++. в отчете предоставить блок-схемы функции : вводится последовательность целых чисел, 0 – конец последовательности.для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – да, 0 - нет).

Ответ:
МудрыйКролик
МудрыйКролик
12.07.2020 01:48
#include <iostream>
int main()
{
    int n;
    bool flag = true;
    std::cin >> n;
    while(n != 0) \\!Ожидаем появления на входе нуля
    {
        while (n >= 10) 
        {
            if(n / 10 % 10 >= n % 10) \\!Сравниваем две последние цифры в числе
                flag = false; \\!Если не совпадает с условием, flag = false, т.е. выведется 0
            n = n / 10;
        }
        std::cout << flag << std::endl;
        flag = true;
        std::cin >> n;
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?