Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
lida113
14.08.2020 03:47 •
Информатика
Составить программу вычисления произведения маленького и наибольшего элементов заданной последовательности чисел.
Ответ:
skatinyatovna
02.10.2020 01:34
Const=10;
var a:array[1..n] of integer;
max,min: integer;
begin
for i:=1 to n do
readln(a[i]);
max:=-32768
min:=32767
for i:=1 to n do
begin
if a[i]<min then min:=a[i];
if a[i]>max then max:=a[i];
end;
writeln(max*min)'
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
MadamHlebushek11
26.01.2021 21:52
Определите количество записей после применения пользовательского фильтра к полю год ...
proshamanfeed
25.05.2020 07:21
Найдите сумму и количество элементов массива , попавших в интервал [a; b]. Границы интервала вводятся с клавиатуры Решите задачу при функции Язык : Pscal Abc...
keramix
13.10.2022 21:41
Какие сочетания клавиш нужно нажать чтобы выделить предложение...
nyto4ek
04.06.2022 12:29
1)региональная метеостанция фиксирует годовые атмосферные осадки в 128 населенных пунктах. за 5 лет наблюдений колебания осадков были в интервале от 100 до 900 мм. специальное...
OtterPop
04.06.2022 12:29
1, данные каких типов могут храниться в ячейках таблицы? 2, каковы основные параметры форматирования абзацев?...
WildOwlXD
04.06.2022 12:29
Установите соотвествие 1.создание текстового документа 2.редактирование текста 3.оформление текста 4.сохранение текста в виде файла 5.загрузга текста с диска 6.печать текстового...
рррр194
13.04.2023 13:33
Как составить предложение на языке из слов best/have/when/day out/did/the/you/и вопросительный знак...
porotnikova03
13.04.2023 13:33
(do) i already my homework for tomorrow. (change) his father jast his car. ! !...
ekaterinavarfo
13.04.2023 13:33
Яне знаю как подчёркивать в предложении части речи: кто-то терем прибирал да хозяев поджидал...
таня43564
13.04.2023 13:33
Несколько предложений на тему облака винительный падеж и именительный падеж...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a:array[1..n] of integer;
max,min: integer;
begin
for i:=1 to n do
readln(a[i]);
max:=-32768
min:=32767
for i:=1 to n do
begin
if a[i]<min then min:=a[i];
if a[i]>max then max:=a[i];
end;
writeln(max*min)'
end.