В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Надо к завтрашнему : составьте программу в паскале вычислите площадь треугольника , две стороны которого равны а и b , а угол между ними равен d (в градусах)

Ответ:
mehan2018
mehan2018
02.10.2020 01:24
Program zd;
const
t=0,5;
var
a,b,c:byte;
r,s:real;
begin
writeln('Введите сторону А');
readln(a);
writeln('Введите сторону В');
readln(b);
writeln('Введите угол С (в градусах)');
readln(c);
r:=c*pi/180; {Перевод из градусов в радианы}
s:=t*a*b*sin(r); {Формула для вычисления}
writeln('Результат = ',s);
readln; {Сразу выводит результат на монитор без нажатия Ctrl+F9 (вроде бы)}
end.
Вроде бы так, попробуй запустить проверить
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?