В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
smarika83
smarika83
23.08.2020 05:43 •  Информатика

Девчата, тут такое затруднение. нужна программа в паскале, только в паскале. условие: напишите программу которая вычисляет среднее арифметическое элементов таблицы а(3*8) . программа по двумерным массивам.

Ответ:
олеся14111
олеся14111
10.07.2020 21:29
Uses crt;
var i,j,k,ni,nj:integer; a:array[1..100,1..100] of integer;
begin
clrscr;
randomize;
ni:=3; nj:=8;
for i:=1 to nj do begin
for j:=1 to ni do
a[i,j]:=random(10);
end;
for i:=1 to nj do begin
for j:=1 to ni do
write(a[i,j],' ' ); writeln;
end;
for i:=1 to nj do begin
for j:=1 to ni do
k:=k+a[i,j];
end;
writeln('sr = ',k);
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?