В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
veraway140
veraway140
29.08.2021 13:07 •  Информатика

1)составьте программу, которая заполняет массив a случайными целыми числами в диапазоне от 1 до 20 и вывода на экран элементов массива с нечётными значениями. 2) соединить : d 1- двоичный код 2- кодирование 3- система счисления 4- основание 5- разряд а- процесс преобразования информации из одной форму представления в другую б- набор из нулей и едениц в- позиция цифры в числе г запичи чисел д- число цифр, которые используются в системе счисления для записи чисел

Ответ:
Huliganka3009
Huliganka3009
10.07.2020 18:18
Const N = 10;
var a: array[1..N] of integer;
  i: integer;
begin
  randomize;
  writeln('исходный массив');
  for i := 1 to N do begin
    a[i] := Random(20) + 1;
    write(a[i]:3);
  end;
  writeln;
  writeln('нечетные значения');
  for i := 1 to N do
    if a[i] mod 2 = 1 then 
      write (a[i]:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?